What are the minimum Apple specs needed to use TouchPoints™ original?

March 28, 2017

In order to use the TouchPoints™ app correctly, you need to have at least iOS Version 9.0 or newer as well as Bluetooth 4.0.